PHPのプラグイン開発で不思議なエラー

WordPressなどのプラグイン開発をしていて、「Cannot modify header information – headers already sent by」というエラーが出たら、ヘッダー処理のエラーなのですけど、エラーの指定行もなにもしていないのに・・・という場合。

プラグインのファイルに<?php ・・・・?>の上下にゴミ改行が入っているだけでこのエラーが出ます。

確認してみてください。他にもエラーになる要素はありますが、プラグイン化する前に

普通に動いていた場合はここを確認。

関連記事

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です

CAPTCHA